Documentation Home
MySQL 5.6 リファレンスマニュアル
Download this Manual
PDF (US Ltr) - 27.1Mb
PDF (A4) - 27.1Mb
EPUB - 7.5Mb
HTML Download (TGZ) - 7.2Mb
HTML Download (Zip) - 7.2Mb


MySQL 5.6 リファレンスマニュアル  /  MySQL のインストールと更新  /  Perl のインストールに関する注釈

2.13 Perl のインストールに関する注釈

PerlDBIモジュールはデータベースアクセスのための一般的なインタフェースを提供します。変更なしで多くの異なったデータベースエンジンで作動する DBI スクリプトを書くことができます。DBI を使用するには、DBI モジュール、および DataBase Driver (DBD) モジュールを、アクセスする各データベースサーバーのタイプごとにインストールする必要があります。MySQL の場合、このドライバは DBD::mysql モジュールです。

MySQL ベンチマークスクリプトを実行する場合は、Perl および DBIDBD::MySQL モジュールがインストールされていなければなりません。セクション8.12.2「MySQL ベンチマークスイート」を参照してください。

注記

MySQL の配布には Perl のサポートは含まれていません。必要なモジュールは、Unix の場合は http://search.cpan.org から、Windows では ActiveState ppm プログラムを使用して取得できます。次のセクションでその方法について説明します。

DBI/DBD インタフェースは Perl 5.6.0 を必要とし、5.6.1 以降が推奨されます。それより古いバージョンの Perl の場合、DBI は機能しませんDBD::mysql 4.009 以上を使用するようにしてください。それより前のバージョンは使用可能ですが、MySQL 5.6 の全機能をサポートしているわけではありません。


User Comments
Sign Up Login You must be logged in to post a comment.