WL#9674: Remove deprecated parameter secure_auth

Affects: Server-8.0   —   Status: Complete   —   Priority: Medium

Remove the deprecated old_password plugin:
* --secure-auth/secure_auth (appears in server and clients)