WL#9636: Rename tx_{read_only,isolation} variables to transaction_*

Affects: Server-8.0   —   Status: Complete   —   Priority: Medium

The system variables for default transaction isolation and read only transaction
are 'tx_read_only' and 'tx_isolation'. This differs from the start up options
which are:
'--transaction_read_only' and '--transaction_isolation'
This naming convention can be quite confusing for users. The bug raised in this
regard BUG#70008.

The variables 'tx_read_only' and 'tx_isolation' are deprecated
in mysql-5.7 and usage of these variables would result in a
deprecation warning. Two aliases for the deprecated variables
have been introduced: 'transaction_read_only' and 'transaction_isolation'.
This ensures that the system variables are in sync with the start up option
names. This also aligns with other transaction related system varaibles like:
transaction_alloc_block_size
transaction_allow_batching
transaction_prealloc_size

In trunk, the variables 'tx_read_only' and 'tx_isolation' are
removed and replaced with 'transaction_read_only' and
'transaction_isolation' respectively.