WL#8927: Deprecate mysql_plugin in 5.7 and remove in 8.0

Affects: Server-8.0   —   Status: Complete   —   Priority: Medium

The mysql_plugin utility does not seem to be in use, by customers, devs or 
support. We do, however, get some bug reports from internal testing, and the
burden to maintain it is noticeable. With changes in 5.7, we are 
dependent on the deprecated --bootstrap option to make it work. In 8.0 this needs 
to be overhauled, if we want to bring the tool forward. 

Therefore, we will deprecate this utility in 5.7, and remove it in 8.0.

User Documentation
==================

For refman-5.7:
http://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-11.html
http://dev.mysql.com/doc/refman/5.7/en/mysql-plugin.html

For refman-8.0, the mysql_plugin section is removed, so there is nothing to 
review.