MySQL Utilities 1.4 Manual  /  ...  /  Fabric Prerequisites

8.1.1. Fabric Prerequisites

Fabric is designed to work with MySQL servers version 5.6.10 and later. The mysqlfabric utility requires Python 2 (2.6 or later) and Connector/Python 1.2.1 or later.

You must have a MySQL instance available to install the backing store. This server must not be a member of a Fabric group.


The backing store must be a MySQL server 5.6 or later.

To utilize Fabric in your applications, you must have a Fabric-aware connector installed on the system where the application is running. For more information about using a connector with Fabric, see the appropriate connector-specific section (Section 8.8, “Using Connector/Python with MySQL Fabric”, Section 8.9, “Using Connector/J with MySQL Fabric”).

In summary, the following items indicate the prerequisites for using MySQL Fabric:

  • MySQL server 5.6.10 or later for Fabric MySQL servers.

  • MySQL server 5.6.x or later for the backing store.

  • Python 2 (2.6 or later) for the mysqlfabric utility.

  • A Fabric-aware connector to use Fabric in applications. Permitted connectors and versions are:

    • Connector/Python 1.2.1 or later

    • Connector/J 5.1.27 or later

Download this Manual
PDF (US Ltr) - 1.1Mb
PDF (A4) - 1.1Mb
EPUB - 292.9Kb
HTML Download (TGZ) - 224.3Kb
HTML Download (Zip) - 236.0Kb
User Comments
Sign Up Login You must be logged in to post a comment.