WL#2752: Backward compatibility e.g version 5.2 emulates 5.1

Affects: Server-7.1   —   Status: Un-Assigned   —   Priority: Very High

This is a request from Robin Schumacher: 
 
"Compatible option ... Allows compatibility 
for those wishing backward behavior" 
 
Possible syntax: SET SQL_MODE='mysql-5.1'; 
 
Possible effect: disallow use of features 
that are in 5.2 but not in 5.1.