Documentation Home
MySQL Workbench Release Notes
Related Documentation Download these Release Notes
PDF (US Ltr) - 0.8Mb
PDF (A4) - 0.8Mb
EPUB - 237.2Kb

MySQL Workbench Release Notes  /  Changes in MySQL Workbench 5.2  /  Changes in MySQL Workbench 5.2.36 (2011-12-03)

Changes in MySQL Workbench 5.2.36 (2011-12-03)

This section documents all changes and bug fixes applied to MySQL Workbench since the release of 5.2.35.

Known limitation: Home, Edit Table Data will load the table in read-only mode. Instead, right-click on a table within the Object Browser and choose the Edit Table Data option from there.

Functionality Added or Changed

  • The Edit, Format, Beautify Query feature no longer quotes column names. (Bug #13030351)

  • The edit context menus, such as Edit Table Data, now open as new tabs. Before they reused (overwrote) the same tab. (Bug #61774, Bug #12731459)

  • If only one server instance is defined, then the Server administration, Manage security option will now automatically connect to it, instead of prompting to choose a server instance. (Bug #61451, Bug #12647697)

  • Indexes are now shown within the schema tree. And indexed columns are also indicated within the table information panel. (Bug #61295, Bug #12616367)

  • The auto_increment information is now displayed within the SQL editor. (Bug #60933, Bug #12402845)

  • On the SQL Editor tabs, right-clicking a tab now offers the following options: New Tab, Save Tab, Close Tab, Close Other Tabs, and Copy Path to Clipboard. (Bug #60883, Bug #12399369)

  • The query and associated results are no longer displayed in separate tabs, but they are now viewable within a single interface. (Bug #60624, Bug #11926853)

  • The SQL editor windows did not have maximize or minimize buttons, but these windows are now opened in configurable tabs. (Bug #60606, Bug #12617245)

  • The export result set dialog has been redesigned, and now saves the previously used settings. (Bug #60490, Bug #11889185)

  • SQL snippets can now be edited, and then saved. (Bug #58879, Bug #11765873)

  • Tab spacing is now defined as 4 on the Linux and Mac platforms, to be consistent with Windows. (Bug #58867, Bug #11765862)

  • A Paste Row context option was added to the Edit Table Data menu of the Object browser. (Bug #58169, Bug #11765228)

  • Additional Export data types were added to the SQL Browser, which now includes JSON, Excel spreadsheet, and MySQL formatted XML. (Bug #56808, Bug #11764024)

  • The Overview tab was replaced, in favor of the new schema tree view. (Bug #56795, Bug #11764014)

  • Added the ability to edit data from a result set after executing a query. If MySQL Workbench determines that a returned result cannot be edited, then a read-only icon will be displayed, and hovering over the icon reveals a tooltip that explains why it cannot be edited. (Bug #56794, Bug #11764013)

  • Added a input field to filter the schema list in the Object Browser. (Bug #55162, Bug #11762554)

  • The Alter table option defaulted to Table view, but now uses the new table editor. (Bug #55050, Bug #11762454)

  • MySQL Workbench did not support the .dbquery file extension. (Bug #54321, Bug #11761795)

  • Added the Copy Inserts to Clipboard option to the Plugins, Objects menu. (Bug #54036, Bug #11761531)

  • Added toolbar buttons to toggle the sidebars and bottom panel of the SQL Editor. (Bug #53714, Bug #11761243)

  • The table view within the Object Browser has changed. The table view includes another level of grouping, which includes Columns, Indexes, Foreign Keys, and Triggers. Before, only the columns were listed. (Bug #53504, Bug #11761050)

  • The table information window within the Object Browser has been expanded to include foreign keys, triggers, indexes, and data types. (Bug #53502, Bug #11761048)

  • The Overview tab was removed, in favor of the new schema layout. (Bug #53323, Bug #11760879)

  • New entries to the error log are now shown when restarting the MySQL server.

    When log_output is set to FILE, the log files are now displayed in the MySQL Workbench log page. (Bug #52445, Bug #11760073)

  • The SQL snippets interface been redesigned and relocated to its own sidebar. Its display may also be toggled. (Bug #50069, Bug #11757950)

  • The SQL Editor history tab now auto-scrolls to the bottom, so that the most recent entry is visible. (Bug #49317, Bug #11757294)

  • Added a new format to the SQL Editor for export, which is identical to the XML generated by the mysql --xml command. It's titled XML (mysql format). (Bug #49305, Bug #11757284)

  • Added the ability to copy Status and System Variables to the clipboard. (Bug #49074, Bug #11757074)

  • The Database, Synchronize Model... dialogue now creates a schema if one does not already exist. (Bug #45025, Bug #11753561)

Bugs Fixed

  • While using the import/restore feature of the server instance administration area, views and routines were not imported. (Bug #13041684)

  • Tables would be listed as Fetching... after pressing the Reconnect DB button. (Bug #13040104)

  • After right-clicking a cell within the insert grid of the model table editor, an unhandled exception was generated on Microsoft Windows, and a fatal error on Mac OS X. (Bug #13029647)

  • The Manage Security window initially shows the first connection as selected, but it is not. (Bug #13026478)

  • While administrating a server instance, importing a project folder will result in an "Import from Disk" error after the following sequence: Data Export and restore, Export to Dump project folder, with Dump views and Dump stored routines... checked, then exporting a schema with views and/or routines, opening the SQL Editor and dropping the exported schema, then clicking Import to Disk within the server administrator. (Bug #13025419)

  • Pressing Refresh within the Slow Query Log tab resulted in an unhandled exception. (Bug #12928308)

  • Within a diagram view, the Edit, Find, Find advanced option was unrecognized and performed no function. (Bug #12884864)

  • A previously selected object could not be dragged, as it would instead enter "Edit Name" mode after the second click. (Bug #12884796)

  • New server instances created by the Manage Server Instance wizard would send the incorrect service name to the MySQL admin. The command is now constructed at run time using the service name from the server instance profile. (Bug #12567371)

  • The Alter Table... option did not function on tables with triggers. (Bug #12546727, Bug #61110)

  • Creating a server instance using unicode characters worked, but an error would be generated while attempting to open them. (Bug #63100, Bug #13350556)

  • Using Alter routine to make changes would sometimes crash after clicking Apply. (Bug #63076, Bug #13340307)

  • Altering and saving a routine twice, reverting, and then clicking Apply would crash MySQL Workbench (Bug #62979, Bug #13492510)

  • On Microsoft Windows, upgrading MySQL Workbench required MySQL Workbench to be run as a user with Administrator rights. (Bug #62709, Bug #13116366)

  • Opening model files while using a MySQL Workbench version that was installed over a previous MySQL Workbench installation would sometimes cause permission issues. The workarounds included running MySQL Workbench with administrator privileges, or removing the installation folder before upgrading. (Bug #62703, Bug #13323929)

  • An unhandled exception might be emitted after modifying an EER diagram, with a popup window reading "MySQL Workbench has encountered a problem - Queue empty." (Bug #62651, Bug #13079826)

  • A query history date would incorrectly change when a history entry, other than the last one, was selected when the query was executed. (Bug #62642, Bug #13104635)

  • The Create Routine... feature would report that it created a routine, but it did not, and the error was revealed in the output window. (Bug #62624, Bug #13362190)

  • Right-clicking on a row within the Inserts tab could crash MySQL Workbench. (Bug #62583, Bug #13365077)

  • The Server Administrator did not function with MySQL Server 5.0. And although MySQL Workbench does not officially support MySQL Server 5.0, this functionality now works. (Bug #62549, Bug #13029339)

  • The Alter Routine wizard would report that a routine was successfully updated, although the routine would remain unchanged. (Bug #62527, Bug #13029468)

  • The Reconnect to DBMS toolbar option would not reconnect after unchecking the Safe Updates preference. A workaround is to uncheck this option, then restart MySQL Workbench. (Bug #62448, Bug #13014798)

  • On Microsoft Windows, and with the Show Live Schema Overview preference disabled, MySQL Workbench would emit an error while attempting to open a Database Connection. (Bug #62407, Bug #13364933)

  • Expanding then collapsing the query results window within the SQL editor, yielded a different appearance. (Bug #62371, Bug #13007096)

  • On Ubuntu 11.10, MySQL Workbench would freeze at the startup splash screen. (Bug #62347, Bug #13099521)

  • Selecting and dragging tables to the diagram area failed. A workaround was to collapse the table list first and then drag it over, although it was only possible to drag a single table. (Bug #62267, Bug #13013851)

  • The Configuration File path within the Server Administration panel is now read-only, when before it would temporarily set the path. This path should be set via the profile setting instead. (Bug #62252, Bug #12922746)

  • Fixed a typo, where "database" was misspelled as "dabase" within the DBDesigner description. (Bug #62250, Bug #12912465)

  • The Auto-save feature would behave with unpredictable results, by opening up an incorrect number of windows when MySQL Workbench was next loaded. (Bug #62192, Bug #12907612)

  • Opening Management, Server Logs would generate an unhandled exception when using table-based logging, while the general log was empty. (Bug #62123, Bug #12872836)

  • After setting a default schema, choosing Refresh all while the schema information is "fetching" would result in an unhandled exception. (Bug #62086, Bug #12913399)

  • Switching between two logins for a single database connection required the password to be reentered with each switch. (Bug #62052, Bug #12921420)

  • On Linux, the Database, Generate Catalog Diff Report... model option was disabled. (Bug #62040, Bug #12844314)

  • Within the Routine Editor, opening multiple Apply SQL Script to Database dialogues and then executing one, except for the last one opened, would crash MySQL Workbench. (Bug #61988, Bug #12918227)

  • On Microsoft Windows, the EER diagram search did not work across multiple pages. (Bug #61957, Bug #12818216)

  • Fixed Data export so that routines and views are only exported when they are selected. In addition, individual views may now be selected for export. (Bug #61937, Bug #12949918)

  • Importing a dump would misquote the --defaults-extra-file option, which would cause the import to fail. (Bug #61910, Bug #12912786)

  • A Download Prerequisites link is now displayed when prerequisites, such as the "Visual C++ 2010 Redistributable Package" requirement, are not met. Before, the link was not visible. (Bug #61897, Bug #12769499)

  • Repeatedly refreshing a schema resulted in an unhandled exception. (Bug #61892, Bug #12762893)

  • The File, Open Recent feature would open the incorrect script. (Bug #61856, Bug #12912374)

  • On Mac OS X, switching from the Model tab to the EER Diagram tab caused an error sound. (Bug #61809, Bug #12757337)

  • File, Export, Forward Engineer SQL CREATE Script would append an extra space to TINYINT(1) after converting it from BOOL. (Bug #61696, Bug #12711138)

  • On Microsoft Windows 7, some MySQL Workbench buttons would be difficult to read due to incompatible background colors with the "Windows classic Style" scheme. (Bug #61685, Bug #12711145)

  • MySQL Workbench would not recognize the active schema with case insensitive servers. As a result, an active schema within the Object browser would be unselected after a USE statement was executed. (Bug #61641, Bug #12711143)

  • The Users and Privileges window did not scale to low screen resolutions like 1024x768. It does now, although MySQL Workbench still has an official minimum screen resolution of 1280x800. (Bug #61518, Bug #12661556)

  • Tab panels within Server Administration would not fresh properly. (Bug #61452, Bug #12647731)

  • The Object editors (such as Alter Table, Alter View, and Alter Routine) now open as tabs, instead of separate wizard windows. (Bug #61422, Bug #12642157)

  • Exporting SQL for tables that included comments would generate invalid SQL statements. A comma was missing immediately before the COMMENT. (Bug #61393, Bug #12627762)

  • After opening a saved model file, the Control+T shortcut would not work from within a query window. (Bug #61379, Bug #12627716)

  • MySQL Workbench could crash while restoring large files. (Bug #61365, Bug #12627685)

  • The Clear script output and Close this script tab buttons are now disabled in non-script tabs. (Bug #61318, Bug #12616331)

  • On Linux, MySQL Workbench failed to open, because it could not load the MySQL Diff Reporting module. (Bug #61304, Bug #12613921)

  • On Linux, code folding for stored procedures and loops did not work properly within the SQL editor. (Bug #61302, Bug #12612394)

  • Pressing Execute after double clicking and editing a field in select all mode, resulted in an unhandled exception. (Bug #61279, Bug #12627523)

  • On Microsoft Windows, the Find option (Control+F) for the SQL editor was not available. (Bug #61233, Bug #12622697)

  • Executing a slow query would not notify the user that the query was running. The new SQL editor interface does show the progress. (Bug #61231, Bug #12589710)

  • While double clicking an arrow to expand a table from within the object browser, to see its columns, the arrow disappeared and the table could not be expanded. (Bug #61124, Bug #12736804)

  • When hovering the mouse pointer over a table figure on a diagram, the foreign key tooltip would hide the table column names. (Bug #61055, Bug #12546715)

  • The default schema selection would be lost after synchronizing a model. (Bug #60975, Bug #12621744)

  • MySQL Workbench would sometimes crash while in Forward Engineering mode. (Bug #60950, Bug #12572071)

  • On Linux and Mac OS X, using Tab and Shift+Tab to jump to next/previous fields has been added to the query result view. It had previously only worked on Windows. Additionally, the Escape key will now cancel editing of the current cell, and PageUp/PageDown scrolls one page up and down in the result set. (Bug #60865, Bug #12368205)

  • Manipulating multiple SQL editor tabs would sometimes result in uncaught exceptions. (Bug #60764, Bug #12621640)

  • MySQL Workbench would crash when attempting to use Alter Table or Create Table from within the context menu. (Bug #60760, Bug #12621510)

  • Fixed a crash bug, which would happen on exit. (Bug #60733, Bug #12632325)

  • If a schema within the schema panel was clicked, then a table was also clicked (dropped down) within the schema, then the panel containing Actions, Schemas, and details would expand to fill half of the view window, and the size could not be adjusted. (Bug #60692, Bug #12587848)

  • The Generate INSERT Statements for Tables option would not generate INSERT statements for BLOG columns. (Bug #60657, Bug #12565791)

  • Factory snippet files were fixed, to include proper line-endings for all platforms. (Bug #60643, Bug #12621434)

  • Closing MySQL Workbench would not prompt to save unsaved work from modified SQL files and windows. (Bug #60557, Bug #11926868)

  • The SQL editor output tab did not report the number of affected rows. (Bug #60535, Bug #12617147)

  • The Synchronize model with Database wizard would not properly handle case-sensitive table names. (Bug #60523, Bug #12617135)

  • Open diagram tabs from a saved MySQL Workbench state were not saved properly. (Bug #60515, Bug #12617096)

  • The Advanced Export Options preferences were not saved, and would reset after restarting MySQL Workbench. (Bug #60497, Bug #11889197)

  • Connection and query tabs can now be reordered, by dragging and dropping with the mouse pointer. (Bug #60409, Bug #11865602)

  • On Linux, viewing the embedded documentation required the python-sqlite2 package. (Bug #60336, Bug #11874507)

  • On Mac OS X, Command+W will now close the active script editor tab, and Command+Shift+W will now close the active connection tab. This is now consistent with behavior on other operating systems. Before, the Command+W combination closed the active connection tab. (Bug #60253, Bug #11829750)

  • Pressing Esc once now escapes out of edit mode within the row editor. Before, it had to be pressed twice. (Bug #60131, Bug #11829997)

  • The Copy Row Content option would throw an unexpected exception, from within a model.

    In addition, the Paste Row option was added. (Bug #60116, Bug #12417533)

  • The USE statement is now properly quoted. For example, an invalid USE query would be generated if a schema contained a - character. (Bug #59882, Bug #11766711)

  • Copying a table column would lose the data type, when only the column line number was selected instead of the data type or field name. (Bug #59285, Bug #11905520)

  • Within a server instance administration panel, setting Export to Self-Contained File to an invalid path resulted in an unhandled exception. (Bug #59246, Bug #11766194)

  • The Output tab of the SQL editor now adjusts whitespace characters, as to display queries on a single line. (Bug #58989, Bug #11765966)

  • Enabling the Limit Rows SQL editor preference would cause invalid SQL syntax with SELECT INTO statements. (Bug #58732, Bug #11765738)

  • When viewing text at a size greater than 100% (such as 125%), some text field labels would be partially hidden. (Bug #58408, Bug #12628507)

  • Server Administration, Manage Import/Export would return an error about the dump module. (Bug #58098, Bug #11765164)

  • MySQL Workbench would allow the creation of foreign keys on tables using engines that do not support them. A warning is now emitted if this is attempted. (Bug #57875, Bug #11764972)

  • MySQL Workbench did not fully adhere to locale settings, which could result in unhandled exceptions. (Bug #56869, Bug #11764077)

  • The Foreign Keys tab of the Alter Table wizard only created an index, without the foreign key. (Bug #56818, Bug #11764033)

  • Broken views (e.g., a column no longer exists) are now displayed as broken within the schema tree view. (Bug #56701, Bug #11763928)

  • Using MySQL Workbench could result in an unhandled exception, with the message "Attempted to read or write protected memory. This is often an indication that other memory is corrupt." (Bug #56034, Bug #11763338)

  • Editor windows would sometimes lose focus, but they are now docked within the main application window, which eliminated this problem. (Bug #55923, Bug #11763235)

  • Auto-scrolling for the SQL output and history windows was added. (Bug #55865, Bug #11763183)

  • The Find feature (search) was replaced with a panel, which offers more consistent behavior across platforms. The Find and Replace feature is also now a panel, instead of a pop-up window. (Bug #54765, Bug #11762197)

  • On Linux, the previously set window positions and sizes were not saved by MySQL Workbench. These settings are now saved upon closing, and used when MySQL Workbench is loaded. (Bug #54025, Bug #11761521)

  • The Finish button was inactive (grayed out) for the Edit Table Data dialog, if the database contained exactly one table. (Bug #52833, Bug #11760422)

  • If a table cannot be edited (e.g., no Primary key), then MySQL Workbench now notifies users of the reason, when before the edit option was simply not available. (Bug #51563, Bug #11759263)

  • Closing and opening the SQL Editor now sets the last used schema as the default, instead of the schema specified within the connection. (Bug #51454, Bug #51026, Bug #11759165, Bug #11758776)

  • A triple-click was required to change the Referenced column of a foreign key, while editing a table within an EER diagram. (Bug #50725, Bug #11758512)

  • Selecting a schema with a large number of tables (e.g., 200+) would indicate that the schema was empty. (Bug #49291, Bug #11757270)

Download these Release Notes
PDF (US Ltr) - 0.8Mb
PDF (A4) - 0.8Mb
EPUB - 237.2Kb